CCNA之交换机Trunk

嗯,学了Vlan就要学trunk了,话说在看使用帮助的时候看到了native,等下要去看看。

  1. Vlan的trunk的话,就是在两个交换机相连接的端口上,告诉端口,这是trunk口。
  2. 然后的话,对于创建vlan实例,要在两个交换机上同时创建,他们不会互相学习。
  3. 但是我们因为做了trunk,所以只需要在一个交换机上对vlan配置ip,即作为PC机器的网关。
  4. 然后另外一个交换机下要创建vlan,然后吧PC机连接到交换机的口划进VLAN。
  5. 最后在PC上面设置好IP就可以通信了。

SW1大致配置如下:(省略了一点自己没有配但是默认会生成的。)

interface Vlan10
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0

interface FastEthernet0/1
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/2
 switchport trunk allowed vlan 10,20
 switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 20
 switchport mode access

SW2大致配置如下:(省略了一点自己没有配但是默认会生成的。)

interface FastEthernet0/1
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/3
 switchport trunk allowed vlan 10,20
 switchport mode trunk
!
interface FastEthernet0/4
 switchport access vlan 10
 switchport mode access

可以参考:Cisco VLAN与trunk配置(简配) https://blog.51cto.com/13276133/1963942

Leave a Reply